Linux 安装 memcache

下载 memcache

wget http://memcached.org/latest

如果没有安装 wget 命令,可以先通过 yum 命令安装 wget 命令

yum install wget

解压并安装

tar -zxvf latest
cd memcached-1.x.x
./configure && make && make test && sudo make install

memcache 依赖 libevent,安装中如果出现

for libevent directory… configure: error: libevent is required.

系统会默认安装 libevent,memcache 找不到是因为没有找到相应头文件

可以通过 yum 安装 libevent-devel,安装 libevent 相关开发使用的头文件

yum install libevent-devel

再次执行

./configure && make && make test && sudo make install

此时可能出现错误

prove ./t
make: prove: Command not found
make: *** [test] Error 127

这是执行 make test 命令抛出的错误,可以忽略,重新执行

sudo make install

安装完成

当以 root 身份安装,可以不使用 sudo 获取权限

作者: 袖之欢

科技改变生活,编程改变世界。

发表评论

电子邮件地址不会被公开。 必填项已用*标注